Configurare un router Cisco 800 con IP statici e firewall.

There is a mobile optimized version of this page, view AMP Version.

Questa è una semplice configurazione per adsl business con 8 ip statici, vi ricordo che sono utilizzabili solo 6 in quanto il primo e l’ultimo sono network e broadcast.

In questo esempio NON utilizzerò il “nat overload” o “PAT” mascherando gli ip privati con I pubblici, questo compito lo svolgerà il firewall.

Pool di indirizzi pubblici: 80.20.20.240 /29

Ip punto-punto: 80.30.30.226 /30

Subnet Lan: 192.168.1.0

 

/—-Inizio configurazione

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname c800
!
enable secret MiaPassword
!
username cisco password MiaPassword2
no aaa new-model
ip subnet-zero
no ip source-route
ip domain name domain.local
ip name-server 8.8.8.8
no ip dhcp conflict logging
!
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
interface Ethernet0
ip address 80.20.20.241 255.255.255.248

ip nat inside

no keepalive
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
ip address 80.30.30.226 255.255.255.252

ip nat outside
pvc 8/35
oam-pvc manage
oam retry 5 5 1
encapsulation aal5snap
!
ip nat pool ext 80.20.20.241 80.20.20.246 netmask 255.255.255.248
access-list 50 permit 80.20.20.241 0.0.0.7
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
no ip http secure-server
!
access-list 50 permit 192.168.1.0 0.0.0.255
line con 0
exec-timeout 240 0
login local
no modem enable
line aux 0
line vty 0 4
exec-timeout 240 0
login local
length 0
!
end

/—-fine configurazione

A questo punto il firewall potrà avere I seguenti indirizzi:

ip outside: 80.20.20.242

ip Inside: 192.168.1.254

next hop: 80.20.20.241

Share

8 pensieri su “Configurare un router Cisco 800 con IP statici e firewall.

  1. Ciao,

    io fatico a trovare il bandolo della matassa. Devo configurare un router Cisco 837 usando il solito banco da 8 IP statici di Telecom. Il mio router però deve solo fornire la connessione a due ZyWall Zyxel che poi fanno tutto il resto (firewall, nat, ecc.) e non riesco a capire come configurare le varie interfacce (ATM, Ethernet e FastEthernet0-4). Non hai un file di esempio che possa adattare alle mie necessità, o consigliare una guida mi aiuti?

    Grazie,
    Filippo

  2. Guarda, la situazione è proprio questa descritta nell’articolo.
    Nell’ATM ci metti il punto-punto fornito da telecom.
    All’interfaccia Fa01 gli assegni il primo indirizzo pubblico.
    La fa01 la colleghi allo switch a cui sono collegati anche i zywall, gli assegni il secondo e terzo ip pubblico e come gateway il primo(cisco).

  3. Uhm, intanto grazie mille.
    Sono riuscito a configurare il mio 837 ma ho un problema che non riesco ad affrontare…
    La running-config è a posto. La salvo sulla startup-config, mi chiede conferma e la salva. Poi però spengo/riacendo il router e mi ritrovo con la configurazione vuota… anche solo se faccio un reload, mi ritrovo sempre alla fatidica domanda “vuoi fare la configurazione iniziale?”…
    Perché? Hai idee?

    Filippo

    • Beh, la prima cosa che mi viene in mente è che hai configurato il registro per non considerare la startup-config.
      prova così:
      c800# conf t
      c800(config)# config-register 0x2102

      Ciao e buona serata.

  4. Yessss!

    Grazie mille, scusa se è sembrato che mi “appoggiassi” molto al tuo aiuto, ho cercato di risultare il più indipendente possibile. Grazie mille comunque!

    Filippo

  5. Salve ho un Cisco 877. Ho resettato el configurazioni del router ho riconfigurato il tutto quando vado a scrivere il comando copy running-config startup-config mi chiede una destinazione io do invio e va avanti. Quando spengo e riaccendo il router si resetta completamente. Cosa posso fare?

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *